Internet-Technologie

Prof. Jürgen Plate

Manualpage tcpdump

TCPDUMP(8)              OpenBSD System Manager's Manual             TCPDUMP(8)

NAME
     tcpdump - dump traffic on a network

SYNOPSIS
     tcpdump [-adeflnNOpqStvxX] [-c count] [-F file] [-i interface] [-r file]
             [-s snaplen] [-T type] [-w file] [expression]

DESCRIPTION
     tcpdump prints out the headers of packets on a network interface that
     match the boolean expression. You must have read access to /dev/bpf*.

     The options are as follows:

     -a      Attempt to convert network and broadcast addresses to names.

     -c count
             Exit after receiving count packets.

     -d      Dump the compiled packet-matching code in a human readable form
             to standard output and stop.

     -dd     Dump packet-matching code as a C program fragment.

     -ddd    Dump packet-matching code as decimal numbers preceded with a
             count.

     -e      Print the link-level header on each dump line.

     -f      Print ``foreign'' internet addresses numerically rather than sym-
             bolically.  This option is intended to get around serious brain
             damage in Sun's yp server -- usually it hangs forever translating
             non-local internet numbers.

     -F file
             Use file as input for the filter expression.  Any additional ex-
             pressions given on the command line are ignored.

     -i interface
             Listen on interface. If unspecified, tcpdump searches the system
             interface list for the lowest numbered, configured ``up'' inter-
             face (excluding loopback).  Ties are broken by choosing the ear-
             liest match.

     -l      Make stdout line buffered.  Useful if you want to see the data
             while capturing it. e.g.,

                   tcpdump -l | tee dat
             or
                   tcpdump -l > dat & tail -f dat

     -n      Do not convert addresses (i.e., host addresses, port numbers,
             etc.)  to names.

     -N      Do not print domain name qualification of host names.  For exam-
             ple, if you specify this flag then tcpdump will print ``nic'' in-
             stead of ``nic.ddn.mil''.

     -O      Do not run the packet-matching code optimizer.  This is useful
             only if you suspect a bug in the optimizer.

     -p      Do not put the interface into promiscuous mode.  The interface
             might be in promiscuous mode for some other reason; hence, -p
             cannot be used as an abbreviation for ``ether host {local-hw-

             addr}'' or ``ether broadcast''.

     -q      Quick (quiet?) output.  Print less protocol information so output
             lines are shorter.

     -r file
             Read packets from a file which was created with the -w option.
             Standard input is used if file is `-'.

     -s snaplen
             Analyze at most the first snaplen bytes of data from each packet
             rather than the default of 68.  68 bytes is adequate for IP,
             ICMP, TCP, and UDP but may truncate protocol information from
             name server and NFS packets (see below).  Packets truncated be-
             cause of a limited snaplen are indicated in the output with
             ``[|proto]'', where proto is the name of the protocol level at
             which the truncation has occurred.  Taking larger snapshots both
             increases the amount of time it takes to process packets and, ef-
             fectively, decreases the amount of packet buffering.  This may
             cause packets to be lost.  You should limit snaplen to the small-
             est number that will capture the protocol information you're in-
             terested in.

     -T type
             Force packets selected by expression to be interpreted as the
             specified type. Currently known types are cnfp (Cisco NetFlow
             protocol), rpc (Remote Procedure Call), rtp (Real-Time
             Applications protocol), rtcp (Real-Time Applications control
             protocol), sack (RFC 2018 No Selective Acknowledgements), vat
             (Visual Audio Tool), and wb (distributed White Board).

     -S      Print absolute, rather than relative, TCP sequence numbers.

     -t      Do not print a timestamp on each dump line.

     -tt     Print an unformatted timestamp on each dump line.

     -ttt    Print day and month in timestamp.

     -v      (Slightly more) verbose output.  For example, the time to live
             and type of service information in an IP packet is printed.

     -vv     Even more verbose output.  For example, additional fields are
             printed from NFS reply packets.

     -w file
             Write the raw packets to file rather than parsing and printing
             them out.  They can be analyzed later with the -r option.  Stan-
             dard output is used if file is `-'.

     -x      Print each packet (minus its link-level header) in hex.  The
             smaller of the entire packet or snaplen bytes will be printed.

     -X      Like -x but dumps the packet in emacs-hexl like format.

     expression
             selects which packets will be dumped.  If no expression is given,
             all packets on the net will be dumped.  Otherwise, only packets
             satisfying expression will be dumped.

             The expression consists of one or more primitives.  Primitives
             usually consist of an id (name or number) preceded by one or more
             qualifiers.  There are three different kinds of qualifiers:

             type   Specify which kind of address component the id name or
                    number refers to.  Possible types are host, net and port.
                    E.g., ``host foo'', ``net 128.3'', ``port 20''. If there
                    is no type qualifier, host is assumed.

             dir    Specify a particular transfer direction to and/or from id.
                    Possible directions are src, dst, src or dst, and src and
                    dst. E.g., ``src foo'', ``dst net 128.3'', ``src or dst
                    port ftp-data''. If there is no dir qualifier, src or dst
                    is assumed.  For null link layers (i.e., point-to-point
                    protocols such as SLIP or the pflog header) the inbound
                    and outbound qualifiers can be used to specify a desired
                    direction.

             proto  Restrict the match to a particular protocol.  Possible
                    protocols are: ether, fddi, ip, arp, rarp, decnet, lat,
                    moprc, mopdl, tcp, and udp. E.g., ``ether src foo'', ``arp
                    net 128.3'', ``tcp port 21''. If there is no protocol
                    qualifier, all protocols consistent with the type are as-
                    sumed. e.g., ``src foo'' means ``(ip or arp or rarp) src
                    foo'' (except the latter is not legal syntax), ``net bar''
                    means ``(ip or arp or rarp) net bar'' and ``port 53''
                    means ``(tcp or udp) port 53''.

                    fddi is actually an alias for ether; the parser treats
                    them identically as meaning "the data link level used on
                    the specified network interface". FDDI headers contain
                    Ethernet-like source and destination addresses, and often
                    contain Ethernet-like packet types, so you can filter on
                    these FDDI fields just as with the analogous Ethernet
                    fields.  FDDI headers also contain other fields, but you
                    cannot name them explicitly in a filter expression.

             In addition to the above, there are some special primitive key-
             words that don't follow the pattern: gateway, broadcast, less,
             greater, and arithmetic expressions.  All of these are described
             below.

             More complex filter expressions are built up by using the words
             and, or, and not to combine primitives.  e.g., ``host foo and not
             port ftp and not port ftp-data''. To save typing, identical qual-
             ifier lists can be omitted.  e.g., ``tcp dst port ftp or ftp-data
             or domain'' is exactly the same as ``tcp dst port ftp or tcp dst
             port ftp-data or tcp dst port domain''.

             Allowable primitives are:

             dst host host      True if the IP destination field of the packet
                                is host, which may be either an address or a
                                name.

             src host host      True if the IP source field of the packet is
                                host.

             host host          True if either the IP source or destination of
                                the packet is host.

                                Any of the above host expressions can be
                                prepended with the keywords, ip, arp, or rarp
                                as in:

                                      ip host host

                                which is equivalent to:

                                      ether proto ip and host host

                                If host is a name with multiple IP addresses,
                                each address will be checked for a match.

             ether dst ehost    True if the Ethernet destination address is
                                ehost. ehost may be either a name from
                                /etc/ethers or a number (see ethers(3) for a
                                numeric format).

             ether src ehost    True if the Ethernet source address is ehost.

             ether host ehost   True if either the Ethernet source or destina-
                                tion address is ehost.

             gateway host       True if the packet used host as a gateway;
                                i.e., the Ethernet source or destination ad-
                                dress was host but neither the IP source nor
                                the IP destination was host. host must be a
                                name and must be found in both /etc/hosts and
                                /etc/ethers. An equivalent expression is

                                      ether host ehost and not host host

                                which can be used with either names or numbers
                                for host/ehost.

             dst net net        True if the IP destination address of the
                                packet has a network number of net. net may be
                                either a name from /etc/networks or a network
                                number (see networks(5) for details).

             src net net        True if the IP source address of the packet
                                has a network number of net.

             net net            True if either the IP source or destination
                                address of the packet has a network number of
                                net.

             dst port port      True if the packet is ip/tcp or ip/udp and has
                                a destination port value of port. The port can
                                be a number or a name used in /etc/services
                                (see tcp(4) and udp(4)). If a name is used,
                                both the port number and protocol are checked.
                                If a number or ambiguous name is used only the
                                port number is checked; e.g., ``dst port 513''
                                will print both tcp/login traffic and udp/who
                                traffic, and ``dst port domain'' will print
                                both tcp/domain and udp/domain traffic.

             src port port      True if the packet has a source port value of
                                port.

             port port          True if either the source or destination port
                                of the packet is port.

                                Any of the above port expressions can be
                                prepended with the keywords tcp or udp, as in:

                                      tcp src port port

                                which matches only TCP packets whose source
                                port is port.

             less length        True if the packet has a length less than or
                                equal to length. This is equivalent to:

                                      len <= length.

             greater length     True if the packet has a length greater than
                                or equal to length. This is equivalent to:

                                      len >= length.

             ip proto proto     True if the packet is an IP packet (see ip(4))
                                of protocol type proto. proto can be a number
                                or one of the names icmp, udp, nd, or tcp. The
                                identifiers tcp, udp, and icmp are also shell
                                keywords and must be escaped.

             ether broadcast    True if the packet is an Ethernet broadcast
                                packet.  The ether keyword is optional.

             ip broadcast       True if the packet is an IP broadcast packet.
                                It checks for both the all-zeroes and all-ones
                                broadcast conventions and looks up the local
                                subnet mask.

             ether multicast    True if the packet is an Ethernet multicast
                                packet.  The ether keyword is optional.  This
                                is shorthand for ``ether[0] & 1 != 0''.

             ip multicast       True if the packet is an IP multicast packet.

             ether proto proto  True if the packet is of ether type proto.
                                proto can be a number or a name like ip, arp,
                                or rarp. These identifiers are also shell key-
                                words and must be escaped.  In the case of
                                FDDI (e.g., ``fddi protocol arp''), the proto-
                                col identification comes from the 802.2 Logi-
                                cal Link Control (LLC) header, which is usual-
                                ly layered on top of the FDDI header.  tcpdump
                                assumes, when filtering on the protocol iden-
                                tifier, that all FDDI packets include an LLC
                                header, and that the LLC header is in so-
                                called SNAP format.

             decnet src host    True if the DECNET source address is host,
                                which may be an address of the form
                                ``10.123'', or a DECNET host name.  DECNET
                                host name support is only available on systems
                                that are configured to run DECNET.

             decnet dst host    True if the DECNET destination address is
                                host.

             decnet host host   True if either the DECNET source or destina-
                                tion address is host.

             ifname interface   True if the packet was logged as coming from
                                the specified interface (applies only to pack-
                                ets logged by pf(4)).

             on interface       Synonymous with the ifname modifier.

             rnr num            True if the packet was logged as matching the
                                specified PF rule number (applies only to
                                packets logged by pf(4)).

             rulenum num        Synonomous with the rnr modifier.

             reason code        True if the packet was logged with the speci-
                                fied PF reason code.  The known codes are:
                                match, bad-offset, fragment, short, normalize,
                                and memory. (applies only to packets logged by
                                pf(4)).

             action act         True if PF took the specified action when the
                                packet was logged.  Known actions are: pass,
                                and block. (applies only to packets logged by
                                pf(4)).

             ip, arp, rarp, decnet, lat, moprc, mopdl
                                Abbreviations for:

                                      ether proto p

                                where p is one of the above protocols.  tcp-
                                dump does not currently know how to parse lat,
                                moprc, or mopdl.

             tcp, udp, icmp     Abbreviations for: ip proto p where p is one
                                of the above protocols.

             expr relop expr    True if the relation holds, where relop is one
                                of `>', `<', `>=', `<=', `=', `!=', and expr
                                is an arithmetic expression composed of inte-
                                ger constants (expressed in standard C syn-
                                tax), the normal binary operators (`+', `-',
                                `*', `/', `&', `|'), a length operator, and
                                special packet data accessors.  To access data
                                inside the packet, use the following syntax:

                                      proto [expr : size]

                                proto is one of ether, fddi, ip, arp, rarp,
                                tcp, udp, or icmp, and indicates the protocol
                                layer for the index operation.  The byte off-
                                set, relative to the indicated protocol layer,
                                is given by expr. size is optional and indi-
                                cates the number of bytes in the field of in-
                                terest; it can be either one, two, or four,
                                and defaults to one.  The length operator, in-
                                dicated by the keyword len, gives the length
                                of the packet.

                                For example, ``ether[0] & 1 != 0'' catches all
                                multicast traffic.  The expression ``ip[0] &
                                0xf != 5'' catches all IP packets with op-
                                tions.  The expression ``ip[6:2] & 0x1fff =
                                0'' catches only unfragmented datagrams and
                                frag zero of fragmented datagrams.  This check
                                is implicitly applied to the tcp and index op-
                                erations.  For instance, ``tcp[0]'' always
                                means the first byte of the TCP header, and
                                never means the first byte of an intervening
                                fragment.

             Primitives may be combined using a parenthesized group of primi-
             tives and operators.  Parentheses are special to the shell and
             must be escaped.  Allowed primitives and operators are:

                   Negation (``!'' or ``not'')
                   Concatenation (``&&'' or ``and'')
                   Alternation (``||'' or ``or'')

             Negation has highest precedence.  Alternation and concatenation
             have equal precedence and associate left to right.  Explicit and
             tokens, not juxtaposition, are now required for concatenation.

             If an identifier is given without a keyword, the most recent key-
             word is assumed.  For example,

                   not host vs and ace

             is short for

                   not host vs and host ace

             which should not be confused with

                   not (host vs or ace)

             Expression arguments can be passed to tcpdump as either a single
             argument or as multiple arguments, whichever is more convenient.
             Generally, if the expression contains shell metacharacters, it is
             easier to pass it as a single, quoted argument.  Multiple argu-
             ments are concatenated with spaces before being parsed.

EXAMPLES
     To print all packets arriving at or departing from sundown:

           tcpdump host sundown

     To print traffic between helios and either hot or ace:

           tcpdump host helios and (hot or ace)

     To print all IP packets between ace and any host except helios:

           tcpdump ip host ace and not helios

     To print all traffic between local hosts and hosts at Berkeley:

           tcpdump net ucb-ether

     To print all FTP traffic through internet gateway snup:

           tcpdump ' gateway snup and (port ftp or ftp-data) '

           The expression is quoted to prevent the shell from mis-interpreting
           the parentheses.

     To print traffic neither sourced from nor destined for local hosts onto
     your local net (if  you gateway to one other net, this stuff should never
     make it):

           tcpdump ip and not net localnet

     To print the start and end packets (the SYN and FIN packets) of each TCP
     connection that involves a non-local host:

           tcpdump ' tcp[13] & 3 != 0 and not src and dst net localnet '

     To print IP packets longer than 576 bytes sent through gateway snup:

           tcpdump ' gateway snup and ip[2:2] > 576 '

     To print IP broadcast or multicast packets that were not sent via Ether-
     net broadcast or multicast:

           tcpdump ' ether[0] & 1 = 0 and ip[16] >= 224 '

     To print all ICMP packets that are not echo requests/replies (i.e., not
     ping packets):

           tcpdump ' icmp[0] != 8 and icmp[0] != 0 '

OUTPUT FORMAT
     The output of tcpdump is protocol dependent.  The following gives a brief
     description and examples of most of the formats.

     Link Level Headers

     If the -e option is given, the link level header is printed out.  On Eth-
     ernets, the source and destination addresses, protocol, and packet length
     are printed.

     On the packet filter logging interface pflog, logging reason (rule match,
     bad-offset, fragment, short, normalize, memory), action taken
     (pass/block), direction (in/out) and interface information is printed out
     for each packet.

     On FDDI networks, the -e option causes tcpdump to print the frame control
     field, the source and destination addresses, and the packet length.  The
     frame control field governs the interpretation of the rest of the packet.
     Normal packets (such as those containing IP datagrams) are ``async''
     packets, with a priority value between 0 and 7; for example, async4. Such
     packets are assumed to contain an 802.2 Logical Link Control (LLC) pack-
     et; the LLC header is printed if it is not an ISO datagram or a so-called
     SNAP packet.

     The following description assumes familiarity with the SLIP compression
     algorithm described in RFC 1144.

     On SLIP links, a direction indicator (`I' for inbound , `O' for
     outbound), packet type, and compression information are printed out.  The
     packet type is printed first.  The three types are ip, utcp, and ctcp. No
     further link information is printed for ip packets.  For TCP packets, the
     connection identifier is printed following the type.  If the packet is
     compressed, its encoded header is printed out.  The special cases are
     printed out as *S+n and *SA+n, where n is the amount by which the se-
     quence number (or sequence number and ack) has changed.  If it is not a
     special case, zero or more changes are printed.  A change is indicated by
     `U' (urgent pointer), `W' (window), `A' (ack), `S' (sequence number), and
     `I' (packet ID), followed by a delta (+n or -n), or a new value (=n). Fi-
     nally, the amount of data in the packet and compressed header length are
     printed.

     For example, the following line shows an outbound compressed TCP packet,
     with an implicit connection identifier; the ack has changed by 6, the se-
     quence number by 49, and the packet ID by 6; there are 3 bytes of data
     and 6 bytes of compressed header:

           O ctcp * A +6 S +49 I +6 3 (6)

     ARP/RARP Packets

     arp/rarp output shows the type of request and its arguments.  The format
     is intended to be self-explanatory.  Here is a short sample taken from
     the start of an rlogin from host rtsg to host csam:

           arp who-has csam tell rtsg
           arp reply csam is-at CSAM

     In this example, Ethernet addresses are in caps and internet addresses in
     lower case.  The first line says that rtsg sent an arp packet asking for
     the Ethernet address of internet host csam. csam replies with its Ether-
     net address CSAM.

     This would look less redundant if we had done tcpdump -n:

           arp who-has 128.3.254.6 tell 128.3.254.68
           arp reply 128.3.254.6 is-at 02:07:01:00:01:c4

     If we had done tcpdump -e, the fact that the first packet is broadcast
     and the second is point-to-point would be visible:

           RTSG Broadcast 0806 64: arp who-has csam tell rtsg
           CSAM RTSG 0806 64: arp reply csam is-at CSAM

     For the first packet this says the Ethernet source address is RTSG, the
     destination is the Ethernet broadcast address, the type field contained
     hex 0806 (type ETHER_ARP) and the total length was 64 bytes.

     TCP Packets

     The following description assumes familiarity with the TCP protocol de-
     scribed in RFC 793. If you are not familiar with the protocol, neither
     this description nor tcpdump will be of much use to you.

     The general format of a tcp protocol line is:

           src > dst: flags data-seqno ack window urgent options

     src and dst are the source and destination IP addresses and ports.  flags
     is some combination of `S' (SYN), `F' (FIN), `P' (PUSH), or `R' (RST),
     `W' (congestion Window reduced), `E' (ecn ECHO) or a single `.' (no
     flags). data-seqno describes the portion of sequence space covered by the
     data in this packet (see example below).  ack is the sequence number of
     the next data expected by the other end of this connection.  window is
     the number of bytes of receive buffer space available at the other end of
     this connection.  urg indicates there is urgent data in the packet.
     options are tcp options enclosed in angle brackets (e.g., <mss 1024>).

     src, dst and flags are always present.  The other fields depend on the
     contents of the packet's tcp protocol header and are output only if ap-
     propriate.

     Here is the opening portion of an rlogin from host rtsg to host csam.

           rtsg.1023 > csam.login: S 768512:768512(0) win 4096 <mss 1024>
           csam.login > rtsg.1023: S 947648:947648(0) ack 768513 win 4096 <mss 1024>
           rtsg.1023 > csam.login: . ack 1 win 4096
           rtsg.1023 > csam.login: P 1:2(1) ack 1 win 4096
           csam.login > rtsg.1023: . ack 2 win 4096
           rtsg.1023 > csam.login: P 2:21(19) ack 1 win 4096
           csam.login > rtsg.1023: P 1:2(1) ack 21 win 4077
           csam.login > rtsg.1023: P 2:3(1) ack 21 win 4077 urg 1
           csam.login > rtsg.1023: P 3:4(1) ack 21 win 4077 urg 1

     The first line says that tcp port 1023 on rtsg sent a packet to port lo-
     gin on host csam.  The `S' indicates that the SYN flag was set.  The
     packet sequence number was 768512 and it contained no data.  The notation
     is `first:last(nbytes)' which means sequence numbers first up to but not
     including last which is nbytes bytes of user data.  There was no piggy-
     backed ack, the available receive window was 4096 bytes and there was a
     max-segment-size option requesting an mss of 1024 bytes.

     Csam replies with a similar packet except it includes a piggy-backed ack
     for rtsg's SYN. Rtsg then acks csam's SYN. The `.' means no flags were
     set.  The packet contained no data so there is no data sequence number.
     The ack sequence number is a 32-bit integer.  The first time tcpdump sees
     a tcp connection, it prints the sequence number from the packet.  On sub-
     sequent packets of the connection, the difference between the current
     packet's sequence number and this initial sequence number is printed.
     This means that sequence numbers after the first can be interpreted as
     relative byte positions in the connection's data stream (with the first
     data byte each direction being 1). -S will override this feature, causing
     the original sequence numbers to be output.

     On the 6th line, rtsg sends csam 19 bytes of data (bytes 2 through 20 in
     the rtsg -> csam side of the connection). The PUSH flag is set in the
     packet.  On the 7th line, csam says it's received data sent by rtsg up to
     but not including byte 21.  Most of this data is apparently sitting in
     the socket buffer since csam's receive window has gotten 19 bytes small-
     er.  Csam also sends one byte of data to rtsg in this packet.  On the 8th
     and 9th lines, csam sends two bytes of urgent, pushed data to rtsg.

     UDP Packets

     UDP format is illustrated by this rwho packet:

           actinide.who > broadcast.who: udp 84

     This says that port who on host actinide sent a udp datagram to port who
     on host broadcast, the Internet broadcast address.  The packet contained
     84 bytes of user data.

     Some UDP services are recognized (from the source or destination port
     number) and the higher level protocol information printed.  In particu-
     lar, Domain Name service requests (RFC 1034/1035) and Sun RPC calls (RFC
     1050) to NFS.

     UDP Name Server Requests

     The following description assumes familiarity with the Domain Service
     protocol described in RFC 1035. If you are not familiar with the proto-
     col, the following description will appear to be written in greek.

     Name server requests are formatted as

           src > dst: id op? flags qtype qclass name (len)

           e.g.,

           h2opolo.1538 > helios.domain: 3+ A? ucbvax.berkeley.edu. (37)

     Host h2opolo asked the domain server on helios for an address record
     (qtype=A) associated with the name ucbvax.berkeley.edu.  The query id was
     3.  The `+' indicates the recursion desired flag was set.  The query
     length was 37 bytes, not including the UDP and IP protocol headers.  The
     query operation was the normal one (Query) so the op field was omitted.
     If op had been anything else, it would have been printed between the 3
     and the `+'. Similarly, the qclass was the normal one (C_IN) and was
     omitted.  Any other qclass would have been printed immediately after the
     A.

     A few anomalies are checked and may result in extra fields enclosed in
     square brackets: if a query contains an answer, name server or authority
     section, ancount, nscount, or arcount are printed as ``[na]'', ``[nn]'',
     or ``[nau]'' where n is the appropriate count.  If any of the response
     bits are set (AA, RA or rcode) or any of the ``must be zero'' bits are
     set in bytes two and three, ``[b2&3=x]'' is printed, where x is the hex
     value of header bytes two and three.

     UDP Name Server Responses

     Name server responses are formatted as

           src > dst: id op rcode flags a / n / au type class data (len)

           e.g.,

           helios.domain > h2opolo.1538: 3 3/3/7 A 128.32.137.3 (273)
           helios.domain > h2opolo.1537: 2 NXDomain* 0/1/0 (97)

     In the first example, helios responds to query id 3 from h2opolo with 3
     answer records, 3 name server records and 7 authority records.  The first
     answer record is type A (address and its data is internet) address
     128.32.137.3.  The total size of the response was 273 bytes, excluding
     UDP and IP headers.  The op (Query) and rcode (NoError) were omitted, as
     was the class (C_IN) of the A record.

     In the second example, helios responds to query op 2 with a rcode of non-
     existent domain (NXDomain) with no answers, one name server and no au-
     thority records.  The `*' indicates that the authoritative answer bit was
     set.  Since there were no answers, no type, class or data were printed.

     Other flag characters that might appear are `-' (recursion available, RA,
     not set) and ``|'' (truncated message, TC, set).  If the question section
     doesn't contain exactly one entry, ``[nq]'' is printed.

     Name server requests and responses tend to be large and the default
     snaplen of 68 bytes may not capture enough of the packet to print.  Use
     the -s flag to increase the snaplen if you need to seriously investigate
     name server traffic.  ``-s 128'' has worked well for me.

     NFS Requests and Replies

     Sun NFS (Network File System) requests and replies are printed as:

           src.xid > dst.nfs: len op args
           src.nfs > dst.xid: reply stat len op results

           sushi.6709 > wrl.nfs: 112 readlink fh 21,24/10.73165
           wrl.nfs > sushi.6709: reply ok 40 readlink "../var"
           sushi.201b > wrl.nfs:
                   144 lookup fh 9,74/4096.6878 "xcolors"
           wrl.nfs > sushi.201b:
                   reply ok 128 lookup fh 9,74/4134.3150

     In the first line, host sushi sends a transaction with ID 6709 to wrl.
     The number following the src host is a transaction ID, not the source
     port.  The request was 112 bytes, excluding the UDP and IP headers.  The
     op was a readlink (read symbolic link) on fh (``file handle'')
     21,24/10.731657119.  If one is lucky, as in this case, the file handle
     can be interpreted as a major,minor device number pair, followed by the
     inode number and generation number.  Wrl replies with a stat of ok and
     the contents of the link.

     In the third line, sushi asks wrl to lookup the name ``xcolors'' in di-
     rectory file 9,74/4096.6878.  The data printed depends on the operation
     type.  The format is intended to be self-explanatory if read in conjunc-
     tion with an NFS protocol spec.

     If the -v (verbose) flag is given, additional information is printed.
     For example:

           sushi.1372a > wrl.nfs:
                   148 read fh 21,11/12.195 8192 bytes @ 24576
           wrl.nfs > sushi.1372a:
                   reply ok 1472 read REG 100664 ids 417/0 sz 29388

     -v also prints the IP header TTL, ID, and fragmentation fields, which
     have been omitted from this example.  In the first line, sushi asks wrl
     to read 8192 bytes from file 21,11/12.195, at byte offset 24576.  Wrl
     replies with a stat of ok; the packet shown on the second line is the
     first fragment of the reply, and hence is only 1472 bytes long.  The oth-
     er bytes will follow in subsequent fragments, but these fragments do not
     have NFS or even UDP headers and so might not be printed, depending on
     the filter expression used.  Because the -v flag is given, some of the
     file attributes (which are returned in addition to the file data) are
     printed: the file type (`REG', for regular file), the file mode (in
     octal), the UID and GID, and the file size.

     If the -v flag is given more than once, even more details are printed.

     NFS requests are very large and much of the detail won't be printed un-
     less snaplen is increased.  Try using ``-s 192'' to watch NFS traffic.

     NFS reply packets do not explicitly identify the RPC operation.  Instead,
     tcpdump keeps track of ``recent'' requests, and matches them to the
     replies using the xid (transaction ID). If a reply does not closely fol-
     low the corresponding request, it might not be parsable.

     KIP AppleTalk (DDP in UDP)

     AppleTalk DDP packets encapsulated in UDP datagrams are de-encapsulated
     and dumped as DDP packets (i.e., all the UDP header information is
     discarded). The file /etc/atalk.names is used to translate AppleTalk net
     and node numbers to names.  Lines in this file have the form

           number          name

           1.254           ether
           16.1            icsd-net
           1.254.110       ace

     The first two lines give the names of AppleTalk networks.  The third line
     gives the name of a particular host (a host is distinguished from a net
     by the 3rd octet in the number; a net number must have two octets and a
     host number must have three octets).  The number and name should be sepa-
     rated by whitespace (blanks or tabs).  The /etc/atalk.names file may con-
     tain blank lines or comment lines (lines starting with a `#').

     AppleTalk addresses are printed in the form

           net.host. port

           e.g.,

           144.1.209.2 > icsd-net.112.220
           office.2 > icsd-net.112.220
           jssmag.149.235 > icsd-net.2

     If /etc/atalk.names doesn't exist or doesn't contain an entry for some
     AppleTalk host/net number, addresses are printed in numeric form.  In the
     first example, NBP (DDP port 2) on net 144.1 node 209 is sending to what-
     ever is listening on port 220 of net icsd-net node 112.  The second line
     is the same except the full name of the source node is known
     (``office''). The third line is a send from port 235 on net jssmag node
     149 to broadcast on the icsd-net NBP port.  The broadcast address (255)
     is indicated by a net name with no host number; for this reason it is a
     good idea to keep node names and net names distinct in /etc/atalk.names.

     NBP (name binding protocol) and ATP (AppleTalk transaction protocol)
     packets have their contents interpreted.  Other protocols just dump the
     protocol name (or number if no name is registered for the protocol) and
     packet size.

     NBP packets are formatted like the following examples:

     icsd-net.112.220 > jssmag.2: nbp-lkup 190: "=:LaserWriter@*"
     jssmag.209.2 > icsd-net.112.220: nbp-reply 190: "RM1140:LaserWriter@*" 250
     techpit.2 > icsd-net.112.220: nbp-reply 190: "techpit:LaserWriter@*" 186

     The first line is a name lookup request for laserwriters sent by net ics-
     di-net host 112 and broadcast on net jssmag.  The nbp ID for the lookup
     is 190.  The second line shows a reply for this request (note that it has
     the same id) from host jssmag.209 saying that it has a laserwriter re-
     source named RM1140 registered on port 250.  The third line is another
     reply to the same request saying host techpit has laserwriter techpit
     registered on port 186.

     ATP packet formatting is demonstrated by the following example:

           jssmag.209.165 > helios.132: atp-req  12266<0-7> 0xae030001
           helios.132 > jssmag.209.165: atp-resp 12266:0 (512) 0xae040000
           helios.132 > jssmag.209.165: atp-resp 12266:1 (512) 0xae040000
           helios.132 > jssmag.209.165: atp-resp 12266:2 (512) 0xae040000
           helios.132 > jssmag.209.165: atp-resp 12266:3 (512) 0xae040000
           helios.132 > jssmag.209.165: atp-resp 12266:4 (512) 0xae040000
           helios.132 > jssmag.209.165: atp-resp 12266:5 (512) 0xae040000
           helios.132 > jssmag.209.165: atp-resp 12266:6 (512) 0xae040000
           helios.132 > jssmag.209.165: atp-resp*12266:7 (512) 0xae040000
           jssmag.209.165 > helios.132: atp-req  12266<3,5> 0xae030001
           helios.132 > jssmag.209.165: atp-resp 12266:3 (512) 0xae040000
           helios.132 > jssmag.209.165: atp-resp 12266:5 (512) 0xae040000
           jssmag.209.165 > helios.132: atp-rel  12266<0-7> 0xae030001
           jssmag.209.133 > helios.132: atp-req* 12267<0-7> 0xae030002

     Jssmag.209 initiates transaction id 12266 with host helios by requesting
     up to 8 packets (the``<0-7>''). The hex number at the end of the line is
     the value of the userdata field in the request.

     Helios responds with 8 512-byte packets.  The ``:n'' following the trans-
     action id gives the packet sequence number in the transaction and the
     number in parentheses is the amount of data in the packet, excluding the
     atp header.  The `*' on packet 7 indicates that the EOM bit was set.

     Jssmag.209 then requests that packets 3 & 5 be retransmitted.  Helios re-
     sends them then jssmag.209 releases the transaction.  Finally, jssmag.209
     initiates the next request.  The `*' on the request indicates that XO
     (exactly once) was not set.

     IP Fragmentation

     Fragmented Internet datagrams are printed as

           (frag id : size @ offset [+])

     A `+' indicates there are more fragments.  The last fragment will have no
     `+'.

     id is the fragment ID.  size is the fragment size (in bytes) excluding
     the IP header.  offset is this fragment's offset (in bytes) in the origi-
     nal datagram.

     The fragment information is output for each fragment.  The first fragment
     contains the higher level protocol header and the fragment info is print-
     ed after the protocol info.  Fragments after the first contain no higher
     level protocol header and the fragment info is printed after the source
     and destination addresses.  For example, here is part of an ftp from ari-
     zona.edu to lbl-rtsg.arpa over a CSNET connection that doesn't appear to
     handle 576 byte datagrams:

           arizona.ftp-data > rtsg.1170: . 1024:1332(308) ack 1 win 4096 (frag 595a:328@0+)
           arizona > rtsg: (frag 595a:204@328)
           rtsg.1170 > arizona.ftp-data: . ack 1536 win 2560

     There are a couple of things to note here: first, addresses in the 2nd
     line don't include port numbers.  This is because the TCP protocol infor-
     mation is all in the first fragment and we have no idea what the port or
     sequence numbers are when we print the later fragments.  Second, the tcp
     sequence information in the first line is printed as if there were 308
     bytes of user data when, in fact, there are 512 bytes (308 in the first
     frag and 204 in the second). If you are looking for holes in the sequence
     space or trying to match up acks with packets, this can fool you.

     A packet with the IP don't fragment flag is marked with a trailing
     ``(DF)''.

     Timestamps

     By default, all output lines are preceded by a timestamp.  The timestamp
     is the current clock time in the form hh:mm:ss.frac and is as accurate as
     the kernel's clock.  The timestamp reflects the time the kernel first saw
     the packet.  No attempt is made to account for the time lag between when
     the Ethernet interface removed the packet from the wire and when the ker-
     nel serviced the ``new packet'' interrupt.

SEE ALSO
     bpf(4), pcap(3)

AUTHORS
     Van Jacobson (van@ee.lbl.gov), Craig Leres (leres@ee.lbl.gov) and Steven
     McCanne (mccanne@ee.lbl.gov), all of the Lawrence Berkeley Laboratory,
     University of California, Berkeley, CA.

BUGS
     Please send bug reports to tcpdump@ee.lbl.gov or libpcap@ee.lbl.gov.

     Some attempt should be made to reassemble IP fragments or, at least to
     compute the right length for the higher level protocol.

     Name server inverse queries are not dumped correctly: The (empty) ques-
     tion section is printed rather than real query in the answer section.
     Some believe that inverse queries are themselves a bug and prefer to fix
     the program generating them rather than tcpdump.

     Apple Ethertalk DDP packets could be dumped as easily as KIP DDP packets
     but aren't.  Even if we were inclined to do anything to promote the use
     of Ethertalk (we aren't, LBL doesn't allow Ethertalk on any of its net-
     works so we'd would have no way of testing this code).

     A packet trace that crosses a daylight saving time change will give
     skewed time stamps (the time change is ignored).

     Filter expressions that manipulate FDDI headers assume that all FDDI
     packets are encapsulated Ethernet packets.  This is true for IP, ARP, and
     DECNET Phase IV, but is not true for protocols such as ISO CLNS. There-
     fore, the filter may inadvertently accept certain packets that do not
     properly match the filter expression.

OpenBSD 3.1                      May 25, 1999                               14

NAME | SYNOPSIS | DESCRIPTION | EXAMPLES | OUTPUT FORMAT | SEE ALSO | AUTHORS | BUGS